Le blog de Jean David TECHER, un Réunionnais à Saint-Priest/Lyon

Aller au contenu | Aller au menu | Aller à la recherche


< 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 >

samedi 19 janvier 2008

Horde: obtenir le contenu des mails en html au lieu de format texte

Il faut modifier le script horde/imp/config/mime_drivers.php en faisant

root@luxy:~# diff -Naur /var/www/horde/imp/config/mime_drivers.php.orig /var/www/horde/imp/config/mime_drivers.php
--- /var/www/horde/imp/config/mime_drivers.php.orig     2008-01-19 10:48:31.000000000 +0100
+++ /var/www/horde/imp/config/mime_drivers.php  2008-01-19 10:55:16.000000000 +0100
@@ -56,14 +56,14 @@
 /**
  * HTML driver settings
  */
-$mime_drivers['imp']['html']['inline'] = false;
+$mime_drivers['imp']['html']['inline'] = true;
 $mime_drivers['imp']['html']['handles'] = array(
     'text/html');
 $mime_drivers['imp']['html']['icons'] = array(
     'default' => 'html.png');
 /* If you don't want to display the link to open the HTML content in a
  * separate window, set the following to false. */
-$mime_drivers['imp']['html']['external'] = true;
+$mime_drivers['imp']['html']['external'] = false;

 /**
  * Image driver settings

FreeRadius et OpenLDAP

Ah yé, j'aurais enfin parvenu à coupler FreeRadius avec OpenLDAP :). Ca m'aura pris du temps mais au moins maintenant, je peux lancer le wifi sur mon portable en utilisant wpa_supplicant. Je rédigerais une doc' la-dessus quand j'aurais du temps. Pour mémo, le contenu du script /etc/wpa_supplicant/wpa_supplicant.conf est
ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="?????"
        scan_ssid=1
        key_mgmt=WPA-EAP
        phase2="auth=PAP"
        identity="USER_LDAP"
        password="PASSWORD_LDAP"
        ca_cert="/etc/wpa_supplicant/certs/root_maison_CA-cacert.pem"
}
L'ajout de phase2="auth=PAP" permet de préciser qu'il faut recourir à l'annuaire LDAP pour l'authentification. Pour automatiser le lancement de FreeRadius au démarrage du serveur, on précise dans le fichier /etc/rc.local
/usr/local/sbin/radiusd -fyzA &
Le fichier de log est /usr/local/var/log/radius/radius.log qui combiné à tail -f donne
tail -f /usr/local/var/log/radius/radius.log
..... ...... ....
..... ...... ....
Sat Jan 19 09:52:10 2008 : Auth: Login OK: [????/????] (from client 192.168.2.1 port 0)

Les fichiers de configuration localisés /usr/local/etc/raddb/ sont

  • radiusd.conf
  • eap.conf
  • clients.conf
  • ldap.attrmap
  • users
Côté client en utilisant wpa_supplicant, dans /etc/network/interfaces, on met
iface eth1 inet dhcp
        wpa-ssid belkin54g
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
auto eth1

Ingo sous Horde pour le filtrage des mails

La semaine dernière j'avais installé une ancienne version de ingo qui me copiait les messages dans les différents répertoires attendus selon les règles de filtres que j'avais fournis. Ce matin, j'ai mis à jour ma version de Ingo et ca marche tranquil On se rend à http://www.horde.org/download/app/?app=ingo et on télécharge la version 1.1.4 et ensuite
cd /var/www/
tar xvzf ingo-h3-1.1.4.tar.gz
mv ingo-h3-1.1.4 horde/ingo
cd horde/ingo/config
for foo in *.dist; do cp $foo `basename $foo .dist`; done
Ensuite, il faut se logguer sous Horde en tant qu'administrateur et il faut configurer horde pour générer le fichier horde/ingo/conf.php. Par défaut, je n'ai rien touché quant à la configuration proposé et ça marche nickel! ;)

Réactivation du blog

Ayé! Après bien des mois d'absence, j'ai décidé de réactiver mon blog. La tâche ne fut pas des plus faciles vu qu'il a fallut rallumer et profiter de moins de 20 minutes pour récupérer le contenu sur mon ancien portable pour le transférer sur le nouvel ACER. Mais bon c'est fait!

Mon ancien portable que j'utilisais pour en faire un serveur ne marche plus! Quand je l'allume, je ne peux en profiter que pendant moins de 20 minutes à cause du processeur qui chauffe à mort. Mais bon comme ancien trophée de mon parcours professionnel, je le garde avec moi.

Avec Cat' aujourd'hui ma vie de couple est terminée depuis déjà au moins deux/trois mois mais bon la vie continue! J'ai tourné la page depuis un petit moment déjà. Il faut pour avancer dans la vie. Je n'en demeure pas moins heureux de ce que je vis ces jours-ci. J'ai récemment eu le temps d'échanger au niveau professionnel avec des gens qui m'ont donné un certain tonus et un nouveau départ.

Et puis il y a Simba, mon petit pépère de tous les jours qui dort tranquillement dans le clic-clac le temps que je rédige ce billet :).